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In the previous tutorial I have explained how to export M2 files from World of 

Warcraft and  import them into Unreal Tournament 3. In this tutorial I will teach you 

the steps needed to import  WMO models from World of Warcraft into Unreal 

Tournament 3. The export proces is totally  different from the M2 tutorial. Because 
WMO models can contain lots of different materials on  one model I have created an 

application to help with the proces of sorting out the order in whi ch the materials 
should be applied to the model.  
 
Please make note of the  rules  set by Blizzard regarding the use of their 

copyrighted assets. This tutorial contains the foll owing topics:  
 

¶ Used Applications  

¶ File Types  

¶ Extract the MPQ Archive  
¶ Converting from WMO to MaxModel  

¶ Converting from MaxModel to ASE  
¶ Using WoW2UT3  

¶ Importing files in UT3  
 
Used  Applications  

 

¶ Ladik's MPQ Editor version 2.0.1.276  

¶ World of Warcraft Model Viewer 0.6.0.3  
¶ Convert WoW Mo dels to Max  

¶ 3ds Max 2009  
¶ Technetium's BLP2 to TGA converter  

¶ Adobe Photoshop CS4  
¶ WoW 2 UT3  

http://www.ladybirdgames.com/
http://www.worldofwarcraft.com/community/machinima/letter.html
http://www.zezula.net/en/mpq/download.html
http://www.wowmodelviewer.org/
http://users.telenet.be/u122561/
http://www.autodesk.com/
http://wowdev.org/files/index.php?act=view&amp;id=39
http://www.adobe.com/
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File  Types  
 

MPQ  
 
MPQ files are archives used by Blizzard which contain the data used in their games. 

For more information about the MPQ file format please check  this wikipedia link . 

 

BLP  

 
BLP or to be precise BLP2 files are used by Blizzard for graphical data like 

textures or other images. BLP files are stored within MPQ archives. For more 
information about the BLP file format please check  this wikipedia link  .  

 

TGA  
 
The TGA file format is a graphics file format which contains image and color data. 

This file format is popular with regards to game development because the ease of 
use and the lack of encumbering patents. UT3 is able to work with TGA files. For 

more information about the TGA file format please check  this wikipedia link  .  

 

WMO  
 
WMO stands for World Map Objects and is used by Blizzard. It is a file format 

containing multiple 3d models, materials and positioning. For more information 
about the WMO file format please check  this link  .  

 

MaxModel  
 
The MaxModel file format is created by Taylor Mouse to export WMO files from World 

of  Warcraft and import them into 3ds Max. For more information please check  this 

link  .  
 

ASE  

 
The 3ds Max ASCII Scene Export (ASE) file format is made by Autodesk. Various 

games like Doom 3 and Unreal Tournament 3 use this file format to import 3d 
models. For more information about the ase file format please check  this link  .

http://en.wikipedia.org/wiki/MPQ
http://en.wikipedia.org/wiki/.BLP
http://en.wikipedia.org/wiki/Truevision_TGA
http://wowdev.org/wiki/index.php/WMO
http://users.telenet.be/u122561/
http://users.telenet.be/u122561/
http://www.modwiki.net/wiki/ASE_(file_format)
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Extract  the  MPQ  Archive  
 

This section is a copy of the Converting MPQ to BLP section of the  Importing WoW 

textures in  UT3 tutorial.  

 
Step  1:  Start Ladik's MPQ Editor  

 

 
 
Step  2:  Select a MPQ  file  
 
Click "File" -> "Open" and browse to  the location of the World of Warcraft Data 

folder on your computer (e.g. C:Workd of WarcraftData), select the file 
"common.MPQ" and click the "Open" button.  
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Step 3: The MPQ's listfile  

The MPQ file format is used in more games then World of Warcraft only. Some older 

games don't have a listfile (list of all the assets within an archive) included in the 
MPQ archive. Luckily for us all the archives provided with World of Warcraft do 

contain a listfile. Therefore you could use the default settings "Open Options" dialog 
box (see the image below).  

 

Step 4: Select the files to be extracted  

The "common.MPQ" file contains the textures we are looking for, but also contains 

thousands of other files which we won't need for this tutoria l. Please feel free to 
export other files as you like, but for this tutorial you will only need the files from the 

"TILESET" directory.  

When you're ready to start the export enter the "Operations" menu and select 
"Extract...".  
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Step 5: Choose a destination location  

The next dialog will let you select you the destination directory for the exported files. 

You are free to place them anywhere you like.  

 

Step 6: The hard part... waiting  

If you have selected all files from "common.MPQ" it could take a few minutes to 
complete the export action. he dialog will disappear when  the action in finished and 

the files are ready to be converted in a usable format.  

 

Converting from WMO to MaxModel  

Step 1: Start World of Warcraft Model View er  

After the Model Viewer is loaded, browse to World -> Wmo -> azeroth -> buildings -
> altarofstorms -> altarofstorms.wmo.  
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This  hierarchy is coming from the directory structure used by Blizzard. Please make 

note of the location of the WoW MPQ archive.  

Step 2: Start Convert WoW Models to Max  

 

Step 3: Select the model to convert  

Click the [Start Converting] button and browse to the location of your MPQ archive. 
Now search the directories for altarofstorms.wmo. When you found the file click the 

[Open] button to start the conversion. The  converted file is now located in the same 
directory as the origional file.  
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Step 4: Copy the Max Script  

To import the MaxModel file in 3ds MAX you need to  have the import script at hand. 

Click [Show Max Script] to view the script file. Right click on the text and choose 
"Select All". Press [CTRL] + [C] on your keyboard to copy the contents of the script 

to the clipboard of the computer. Open notepad.exe or any other simple text editing 
tool and paste ([CTRL] + [V]) the contents of the max script into an empty file. Save 

the file with an .ms extention.  

 

Converting from MaxModel to ASE  

Step 1: Open 3ds Max and Run the Import Script  

Go to the "MAXScript" menu and choose "Run Script...". Browse to the location of the 
max script from the previous step.  
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Step 2: Select the MaxModel  

After the max script is run it will ask for the location where your MaxModel file is 

located. Click the "Open" button to start the i mport.  

 

If everything went well, you'll now see the conents of the MaxModel being displayed 
in the views of 3ds Max.  
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Step 3: Select one object  

Because a WMO contains multiple objects it is necessary to merge them into one 

single object, otherwise UT3 can't handle the object very well. Select one object by 
clicking it at t he Perspective view of 3ds Max. Click the "Modify" tab and browse to 

the "Edit Geometry" section. Click the [Attach List] button.  

 

Step 4: Attach all objects  

Select all object by pressing [CTRL[ + [A] and click the [Attach] button.  
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An Attach Options dialog will appear. You should keep the default options. Click [OK] 

to proceed.  

\  

Step 5: Center the Pivot Point  

Go to the "Hierarchy" tab. Select the object by clicking it in one of the views. Select 
the "Affect Pivot Only" option and click the [Center to Object] button.  
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Step 6: Export the ASE file  

In the "File" menu select "Export..." and browse to the directory you want to use for 

your static mesh. Enter a name and click [Save] to proceed.  

 

The ASCII Export options dialog will appear. Use the settings from the image below 

as default, but feel free to experiment with these settings.  
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Using WoW2UT3  

WoW 2 UT3 is an application used to make the next step an easy one. The "Altar of 

Storms" 3d model contains nine different material layers all with their own im age file. 

Usualy you needed to search for all the used texture files and convert them manually 
to TGA files. Next you needed to search within the ASE file to extract the order in 

which the materials are used. These steps would be very time consuming. Becau se I 
needed many different 3d models from WoW for my project at school I made an 

application which does these time consuming steps in a few seconds time. You will 
find a download link to WoW2UT3 on this site. Make sure that it is installed and setup 

proper ly befor e continuing with this tutorial.  

Step 1: Open WoW 2 UT3  

Open WoW 2 UT3 and fill in the location of the ASE file and the location where you 

want to export the converted files to. Make sure the "Export Material List" and the 
"Convert BLP to TGA" opti ons are marked.  
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Click [Convert] to start the export and convert process.  

 

Browse to your destination directory. You will see a *.txt document and a few 
different *.tga files.  

 

In the textfile the order of the materials are given. This is a nice feature which will 

help you while constructing the static mesh after being imported int o UT3.  
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Importing files in UT3  

Step 1: Flip the images  

Before we switch to UT3 there is one thing to do. At the conversion of BLP to TGA the 
images were fli pped. We need to correct this before importing them into UT3 because 

otherwise the static mesh will look out of place. Open PhotoShop or any other image 
tool capable of flipping TGA files. Open an exported TGA file. In PhotoShop go to the 

"Image" menu and select "Image Rotation" -> "Flip Canvas Vertical". Now save the 
file. It is OK to overwrite the TGA file because nothing has been done that could harm 

the file in any way. Repeat the process for all the exported images.  

 

Step 2:  Open the Unreal Tournament 3 Editor  
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Step 3:  Open the Generic Browser  

Open the Generic Browser and make sure you select the material, static mesh and 

texture resource types.  

 

Browse to the directory where you've saved your ASE file from the previous section. 

Click "Open" to continue. Select the package name where you woul d like to import 
the assets.  
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Step 4: Import the TGA Textures  

After importing the ASE file you need to import the TGA filles which will be used as 

materiasl for t he static mesh. You can select more the one file in the browser window. 
Make sure you save the textures in the same package as the imported static mesh. 

Also make sure you select "Create Material" within the Import dialog box. Click [OK to 
All] to apply th e same settings on all the selected TGA files.  

 

Step 5: Save the package  

Find the package you've just created in the package list to the bottom left of the 
generi c browser and right click the package. Choose "Save.." and select a name and 

a locatino for your new pacakge.  
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Step 6: Apply the Materials to the Static Mesh  

Right  click the static mesh within the generic browser and select "Static Mesh Editor".  

 

In t he Static Mesh Editor you can unselect the "UseSimpleBoxCollision", 
"UseSimpleLineCollision" and "UseSimpleRigidBodyCollision". This way the collision 

detection will work on a per poly base. Open the "LODInfo" -> [0] -> "Elements" 
section. What you will se e are the material slots that need to be filled with the right 

materials in the right order.  
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Order you screen in a way the material order llist you've created wi th WoW2UT3, the 

generic browser and the static mesh editor can be visible without huge overlaps. The 
most easy way to apply the materials to the static mesh is by opening all material 

slots first and then watch the first entry in the order list. Find that material in the 
generic browser and apply the material into the same material element by clicking 

the green arrow. Repeat these steps for all the available layers. Save the package 
when done.  

 

  


